Bug #4092

Invalid option 'None' in multichoice dropdowns in Event search

Added by Radko Krkoš 11 months ago. Updated 9 months ago.

Status:ClosedStart date:05/15/2018
Priority:LowDue date:
Assignee:Radko Krkoš% Done:

100%

Category:Development - GUI
Target version:2.0

Description

Several multichoice dropdowns on Event search contain the option 'None’ which, when selected, results the Search to fail with "'None’ is not a valid choice for this field”.

How to reproduce:
  1. Set up query with Severities set to 'None’, press 'Search’
  2. A warning "'None’ is not a valid choice for this field” appears below the Severities multichoice element.
  • Behavior confirmed for other multichoices offering 'None’ option (Source types, Categories, Classes, ...)
  • Option 'None’ appears for columns containing NULL values at data level. Correct behaviour therefore probably is:
    ... WHERE "cesnet_eventseverity" is NULL ...
    or (in case of multi selection):
    ... WHERE "cesnet_eventseverity" is NULL OR "cesnet_eventseverity" = ANY(ARRAY[#1, #2, ...]) ...

Related issues

Related to Mentat - Bug #4091: Option "<< no preference >>" for multichoice selectors in... Closed 05/15/2018

Associated revisions

Revision 85fc0c01
Added by Jan Mach 11 months ago

Fix: Fixed the invalid options 'None’ to be among the distinct values for various event columns.

Issue reported by Radko Krkoš, resolved. (Redmine issue: #4092)

History

#1 Updated by Radko Krkoš 11 months ago

  • Priority changed from Normal to Low

#2 Updated by Jan Mach 11 months ago

  • Status changed from New to Resolved
  • Assignee changed from Jan Mach to Radko Krkoš

Attached commit resolves the issue, it can be closed.

#3 Updated by Jan Mach 11 months ago

  • Related to Bug #4091: Option "<< no preference >>" for multichoice selectors in Event search translates to probably unintended query added

#4 Updated by Radko Krkoš 11 months ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Revision 85fc0c01 removed the 'None’ option. Filtering for untagged events is facilitated by the ”<< without value >>” option. Fixed.

#5 Updated by Jan Mach 9 months ago

  • Target version set to 2.0
  • Parent task deleted (#3734)

Also available in: Atom PDF