Project

General

Profile

Feature #6254

Detector list in Event search result table is not populated by all Nodes from original IDEA

Added by Radko Krkoš 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Development - GUI
Target version:
Start date:
03/05/2020
Due date:
% Done:

0%

Estimated time:
To be discussed:
Yes

Description

There are events in Mentat, where the Detector only contains some of the Nodes from the original IDEA. It was discovered for iABU messages with nodes “cz.cesnet.sabu_testbed.warden_filer” and “cz.cesnet.tarpit”, where only the latter is visible as Detector in the Event search list (while the first one is the true detector). The node_name array in the DB contains both, so this is a very strange bug.

Sample event:
https://mentat-hub.cesnet.cz/mentat/events/a52b5673-21c5-4d96-9a6d-219fe97fa7fa/show

Another event, displays as “cz.cesnet.sabu_testbed.warden_filer”, while “cz.cesnet.tarpit” is only in Note, the same node, day and hour:
https://mentat-hub.cesnet.cz/mentat/events/9e0377cf-4db9-4ed6-8cf8-3fe71b0e9a2d/show

#1

Updated by Radko Krkoš 5 months ago

  • Category changed from Development - Database to Development - GUI

This is an issue in GUI only, the DB seems correct, the searching also looks good.

#2

Updated by Jan Mach 5 months ago

  • Tracker changed from Bug to Feature
  • Status changed from New to Feedback
  • Assignee changed from Jan Mach to Radko Krkoš
  • To be discussed changed from No to Yes

This is not a bug, but a design choice. The general idea is that when event is passing through relay nodes these nodes may append information about themselves to indicate that particular event passed through them. This is similar mechanism to adding Received headers in email protocol. The event search result table deliberately displays only the first item from Node[] list, because it is the originator of the message and usually what the user is interested in. Displaying information about all relay nodes would bloat the table and in most cases this information is useless. Whether this should be changed is up to the discussion, but it is a design choice, not a bug.

#3

Updated by Radko Krkoš 5 months ago

  • Assignee changed from Radko Krkoš to Jan Mach

Jan Mach wrote:

The event search result table deliberately displays only the first item from Node[] list, because it is the originator of the message and usually what the user is interested in.

Except that in this case, that is not true. Not the first, but the second Node is displayed (sorry I have not stressed this more in the original message).

mentat_events=# SELECT node_name FROM events WHERE id = 'a52b5673-21c5-4d96-9a6d-219fe97fa7fa';
                       node_name                        
--------------------------------------------------------
 {cz.cesnet.sabu_testbed.warden_filer,cz.cesnet.tarpit}
#4

Updated by Jan Mach 5 months ago

OK, no more speculations and retrieving information from memory:

{%- set tmpval = item.get_detectors() %}
{%- if tmpval %}
{{
    macros_site.render_widget_csag_detector(
        [tmpval[-1]],
        form_data['detectors'],
        align_right = True,
        separate_dropdown = False
    )
}}

So the idea is reverse from what I vaguely recovered from memory and stated before, last item is displayed, relays prepend. But it still is a deliberate choice (tmpval[-1]).

#5

Updated by Jan Mach 5 months ago

  • Assignee changed from Jan Mach to Radko Krkoš
#6

Updated by Radko Krkoš 5 months ago

  • Status changed from Feedback to Rejected
  • Target version changed from Backlog to Rejected

Whoa, code quotations... Let’s stay civil...

OK, I understand. This is still an error, but it should be fixed in the detector. Closing rejected.

Also available in: Atom PDF