Project

General

Profile

Actions

Bug #7686

closed

Whitespace(s) around IPs cause parsing problem

Added by Jakub Judiny 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Development - GUI
Target version:
Start date:
10/25/2023
Due date:
% Done:

0%

Estimated time:
To be discussed:
No

Description

When using e.g. NERD service in Mentat, typing " 104.17.96.13" instead of "104.17.96.13" shows following error message: The " 104.17.96.13" value does not look like valid IPv4 address. . The problem is present not only in validation, but also when searching in services without validation, for example in DNS resolving. Network record create form also needs to be fixed. Event and timeline searching is without problems, because ipranges library is not used there.


Related issues

Related to Mentat - Bug #7613: Various fields insist on interpreting whitespaceClosedJakub Maloštik10/21/2022

Actions
Actions #1

Updated by Jakub Judiny 8 months ago

  • Related to Bug #7613: Various fields insist on interpreting whitespace added
Actions #2

Updated by Jakub Judiny 8 months ago

  • Status changed from New to Resolved
Actions #3

Updated by Rajmund Hruška 8 months ago

  • Status changed from Resolved to In Review
Actions #4

Updated by Rajmund Hruška 8 months ago

  • Status changed from In Review to Closed
Actions

Also available in: Atom PDF