Project

General

Profile

Actions

Bug #6157

closed

MaxMind changes acces to its free GeoIP dbs

Added by Pavel Kácha over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Development - Core
Target version:
Start date:
01/02/2020
Due date:
% Done:

100%

Estimated time:
To be discussed:
No

Description

As described in https://blog.maxmind.com/2019/12/18/significant-changes-to-accessing-and-using-geolite2-databases/, GeoIP changed database access policy. Because of assumed legal problems, db is still free, but access is tied to an account now. So we'll need something akin to:

  • rewrite GeoIpEnricherPlugin to use the new access method
  • add configuration options for Maxmind credentials
  • update docs to advise admins to create Maxmind account
Iff we really need/want GeoIP enrichment in Cesnet Mentat instance:
  • create account and configure creds ourselves for Cesnet
Or:
  • use different source of GeoIP data
Or:
  • drop the plugin altogether

Related issues

Related to Mentat - Bug #6156: Enricher GeoipEnricherPlugin crashes on nonexistent GeoIP fileRejectedJan Mach01/02/2020

Actions
Actions #1

Updated by Radko Krkoš over 2 years ago

Option 3 does not follow the predicate.

Actions #2

Updated by Pavel Kácha over 2 years ago

Radko Krkoš wrote:

Option 3 does not follow the predicate.

I never set out to be consistent.

BTW seems there are alternatives, even in (drop-in) mmdb format: https://db-ip.com/db/lite.php
(So that might be cheapest - in terms of manhours - alternative.)

Actions #3

Updated by Jan Mach over 2 years ago

  • Status changed from New to In Progress

Pavel Kácha wrote:

Radko Krkoš wrote:

Option 3 does not follow the predicate.

I never set out to be consistent.

BTW seems there are alternatives, even in (drop-in) mmdb format: https://db-ip.com/db/lite.php
(So that might be cheapest - in terms of manhours - alternative.)

There is no need to make any changes in GeoIP enricher plugin. It is only needed to change the utility script fetch-geoipdb.sh, that is being launched periodically via cron and takes care of downloading latest free GeoIP data files. I think it is valid to require that the administrator registers account to enable downloading these files in case he wishes to use this feature. The https://db-ip.com/db/lite.php alternative does not support free IP to ASN database, so there would be a regression.

Actions #4

Updated by Jan Mach over 2 years ago

  • Target version changed from Backlog to 2.6
Actions #5

Updated by Jan Mach over 2 years ago

  • Related to Bug #6156: Enricher GeoipEnricherPlugin crashes on nonexistent GeoIP file added
Actions #6

Updated by Jan Mach over 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100
  • To be discussed changed from Yes to No

I have removed all scripts and configuration related to retrieving GeoIP databases from MaxMind. Recommended approach is to use their geoipupdate utility. Documentation was updated to reflect these changes, administrator is required to install and configure geoipupdate utility himself and make sure there will be IP geolocation database files present on target system that the Mentat system can then use. It is now listed as installation prerequisite. It is not possible to use Debian package dependency system for this, because Debian packages are provided, but they are not available in the repositories.

For convenience the ansible role was created to help with this task. I now consider this issue to be resolved.

Actions

Also available in: Atom PDF