Project

General

Profile

Actions

Feature #6310

closed

Implement result caching

Added by Pavel Kácha about 4 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Development - Core
Target version:
Start date:
07/08/2020
Due date:
07/08/2020
% Done:

0%

Estimated time:
To be discussed:
No

Description

Implement caching of query results for Alerts, Timeline and possibly others.

Makes sense possibly only after #6309.


Related issues

Related to Mentat - Feature #6311: Consider reimplementing multi-field statistics in terms of event count percents ClosedPavel Kácha04/09/2020

Actions
Related to Mentat - Task #4228: Hawat: Make use of Flask-Cache pluginRejected07/27/2018

Actions
Is duplicate of Mentat - Feature #6332: Improve searching with caching and JavaScriptFeedbackJakub Maloštik07/08/202007/08/2020

Actions
Blocked by Mentat - Feature #6309: Fix ending timestamp after query submissionClosedJan Mach04/09/2020

Actions
Follows Mentat - Feature #6413: Autarkic DB queries for timelineClosedJakub Maloštik07/07/2020

Actions
Actions #1

Updated by Pavel Kácha about 4 years ago

  • Blocked by Feature #6309: Fix ending timestamp after query submission added
Actions #2

Updated by Pavel Kácha about 4 years ago

  • Related to Feature #6311: Consider reimplementing multi-field statistics in terms of event count percents added
Actions #3

Updated by Pavel Kácha about 4 years ago

  • Related to Task #4228: Hawat: Make use of Flask-Cache plugin added
Actions #4

Updated by Radko Krkoš almost 4 years ago

  • Due date set to 07/08/2020
  • Start date changed from 04/09/2020 to 07/08/2020
  • Follows Feature #6413: Autarkic DB queries for timeline added
Actions #5

Updated by Pavel Kácha about 3 years ago

  • Assignee deleted (Jan Mach)
Actions #6

Updated by Pavel Kácha about 1 month ago

  • Is duplicate of Feature #6332: Improve searching with caching and JavaScript added
Actions #7

Updated by Pavel Kácha about 1 month ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF