Project

General

Profile

Actions

Bug #6414

closed

Timeline pre-generated time bounds are not respected

Added by Radko Krkoš about 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Development - Core
Target version:
Start date:
07/07/2020
Due date:
% Done:

0%

Estimated time:
To be discussed:
No

Description

The timeline form is loaded with a pre-defined time interval bounds, based on current hour. These bounds are then not used and the results are given for a superinterval since midnight before lower bound until midnight after upper bound.

Example:
Detection time from: 2020-06-30 15:00:00
Detection time to: 2020-07-07 15:00:00

Actual query:

SELECT generate_series('2020-06-30T00:00:00'::timestamp, '2020-07-08T00:00:00'::timestamp, '0 days 3600.000000 seconds'::interval) AS bucket ORDER BY bucket

The results match the time interval in the query, so the bounds as shown in the form are not respected.

Actions #1

Updated by Radko Krkoš about 4 years ago

After more testing, this seems intentional, the interval is extended to a full week.

Actions #2

Updated by Jan Mach about 4 years ago

  • Status changed from New to Feedback
  • Assignee changed from Jan Mach to Radko Krkoš

Radko Krkoš wrote in #note-1:

After more testing, this seems intentional, the interval is extended to a full week.

This indeed is a feature, not a bug. Whether it is optimal solution is up for a debate, since it got you confused, maybe the thresholds set by the user should be enforced. However the idea was to present user with nicely rounded time intervals, which means sometimes the thresholds need to be increased to be able to use nice time bucket sizes.

Actions #3

Updated by Radko Krkoš over 3 years ago

  • To be discussed changed from Yes to No
Actions #4

Updated by Radko Krkoš over 3 years ago

  • Status changed from Feedback to Deferred
  • Assignee deleted (Radko Krkoš)

No decision was made one way or the other, currently there are more pressing issues. Deferring.

Actions #5

Updated by Radko Krkoš almost 2 years ago

  • Assignee set to Jakub Maloštik
  • Target version changed from Backlog to 2.11

As discussed on the meeting, timeline looks like a good place to start hacking Mentat right now.

Actions #6

Updated by Jakub Maloštik over 1 year ago

  • Status changed from Deferred to In Progress
Actions #7

Updated by Jakub Maloštik over 1 year ago

  • Status changed from In Progress to Resolved
Actions #8

Updated by Rajmund Hruška over 1 year ago

  • Status changed from Resolved to In Review

Merged into devel and deployed on mentat-alt.

Actions #9

Updated by Rajmund Hruška about 1 year ago

  • Status changed from In Review to Closed
Actions

Also available in: Atom PDF