Project

General

Profile

Actions

Config #6480

closed

Check the postgresql.conf file for missing options added in later PostgreSQL versions

Added by Radko Krkoš over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installation
Target version:
Start date:
08/21/2020
Due date:
% Done:

0%

Estimated time:
To be discussed:

Description

As was found during #6474 (an PassiveDNS issue), some options added in the new PostgreSQL version might be not present in the configuration file after the upgrade. The configuration file must be compared to the default template of the current running version and the differences must be merged.
Also, the upgrade process for the database must be extended to perform the diff and merge. This step should also be mentioned in the migration documentation.
So far, there seem to be no problems caused by this in Mentat.

Actions

Also available in: Atom PDF