Project

General

Profile

Actions

Bug #7623

closed

Enabling user shows message that it was unsuccessful

Added by Rajmund Hruška over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
Development - GUI
Target version:
Start date:
01/31/2023
Due date:
% Done:

100%

Estimated time:
To be discussed:

Description

It says Unable to enable user account testuser22. , but the user is in fact enabled. So the action is successful but the prompt says otherwise.


Related issues

Related to Mentat - Bug #7687: Any operation with filter shows message that it was unsuccessful (in dev)ClosedJakub Judiny10/25/2023

Actions
Actions #1

Updated by Rajmund Hruška over 1 year ago

I think the issue might be present only when the mail service is not configured. I tested on my local machine, the issue is present. But mentat-alt and mentat-hub seem to not have this issue.

Actions #2

Updated by Rajmund Hruška over 1 year ago

  • Status changed from New to Resolved
  • Assignee set to Rajmund Hruška
  • % Done changed from 0 to 100
  • To be discussed changed from No to Yes

So, this is only present when mail service is not set up. My suggested solution (d73b94bc) is to just try to send the email and do nothing if that fails. And by doing nothing I mean actually enabling the user and showing success message.

Actions #3

Updated by Rajmund Hruška over 1 year ago

  • To be discussed deleted (Yes)

As it was discussed on the meeting, I have added logging.

Actions #4

Updated by Rajmund Hruška over 1 year ago

  • Status changed from Resolved to Closed
Actions #5

Updated by Jakub Judiny 9 months ago

  • Related to Bug #7687: Any operation with filter shows message that it was unsuccessful (in dev) added
Actions

Also available in: Atom PDF