Project

General

Profile

Actions

Support #7650

open

Replace nvd3 Javascript library

Added by Jakub Judiny about 1 year ago. Updated 3 days ago.

Status:
In Review
Priority:
Normal
Category:
-
Target version:
Start date:
05/02/2023
Due date:
% Done:

0%

Estimated time:
To be discussed:
No

Description

"" has peer dependency "d3@^3.4.4", which stops us from upgrading d3 (newest version of d3 at the moment is 7.8). Nvd3 will most probably not recieve any updates, so it has to be replaced by other similar library (like Vega or possibly other library).


Related issues

Related to Mentat - Support #7632: Mentat dependencies upgradeClosedJakub Judiny02/28/2023

Actions
Related to Mentat - Task #4494: Redesign JS portion of the Hawat web interfaceNew01/08/2019

Actions
Actions #1

Updated by Jakub Judiny about 1 year ago

Actions #2

Updated by Jakub Judiny about 1 year ago

  • Tracker changed from Task to Support
Actions #3

Updated by Rajmund Hruška 9 months ago

  • Related to Task #4494: Redesign JS portion of the Hawat web interface added
Actions #4

Updated by Jakub Maloštik 8 months ago

  • Assignee set to Jakub Maloštik
Actions #5

Updated by Jakub Maloštik 8 months ago

  • Status changed from New to In Progress
Actions #6

Updated by Jakub Judiny 3 months ago

  • Target version changed from Backlog to 2.13
Actions #7

Updated by Jakub Maloštik about 2 months ago

  • Status changed from In Progress to Resolved
Actions #8

Updated by Pavel Kácha 27 days ago

  • Status changed from Resolved to Feedback

From today's meeting:

  • the axes should have a legend (detect time, event count, ...)
  • pie chart download should also have a legend (on the web the legend is the table)
Actions #9

Updated by Jakub Maloštik 27 days ago

  • Status changed from Feedback to Resolved
Actions #10

Updated by Rajmund Hruška 20 days ago

  • Status changed from Resolved to In Review
Actions #11

Updated by Jakub Maloštik 18 days ago

Pandas seems to be throwing the following error

[Thu May 09 14:51:23.798647 2024] [wsgi:error] [pid 2693] /var/mentat/venv/lib/python3.7/site-packages/pandas/__init__.py:11: UserWarning: NumPy was imported from a Python sub-interpreter but NumPy does not properly support sub-interpreters. This will likely work for most users but might cause hard to track down issues or subtle bugs. A common user of the rare sub-interpreter feature is wsgi which also allows single-interpreter mode.
[Thu May 09 14:51:23.798714 2024] [wsgi:error] [pid 2693] Improvements in the case of bugs are welcome, but is not on the NumPy roadmap, and full support may require significant effort to achieve.

Actions #12

Updated by Pavel Kácha 6 days ago

Note: if there's change in Apache config, we will need to mention it in Release notes.

Actions #13

Updated by Rajmund Hruška 3 days ago

Pavel Kácha wrote in #note-12:

Note: if there's change in Apache config, we will need to mention it in Release notes.

And updating the one used in Vagrant would be also helpful.

Actions

Also available in: Atom PDF