Project

General

Profile

Actions

Bug #6209

closed

Reenable Metacentrum network list update

Added by Pavel Kácha over 4 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Development - Tools
Target version:
Start date:
01/31/2020
Due date:
% Done:

0%

Estimated time:
To be discussed:
No

Description

Once upon a time there was an automatic update of the list of Meta networks into the __GRID__ abuse group. It's gotten lost in the chasms of ages, however we might boldly draw it back to light.

List is accessible at https://mailman.metacentrum.cz/share/certs/hosts_list (use wget or curl, not browser, as it is too clever in SSL renegotiation).

In the history, the list was downloaded at ir.cesnet.cz and uploaded to :iplist-grid. Mek, there must have been some script somewhere, which took this data and updated the group - so for start, please, try to search for this code, update then should be straightforward.


Related issues

Related to Mentat - Feature #6227: Incorporate new info from Negistry into group db and reportingClosedRajmund Hruška04/29/2021

Actions
Is duplicate of Mentat - Feature #7725: Import Metacentrum networks as an externally updated feedResolvedRajmund Hruška04/10/2024

Actions
Actions #1

Updated by Jan Mach about 4 years ago

  • Target version changed from 2.7 to 2.8
Actions #2

Updated by Pavel Kácha over 3 years ago

  • Target version changed from 2.8 to 2.9
Actions #3

Updated by Pavel Kácha over 3 years ago

  • Status changed from New to Deferred
  • Assignee deleted (Jan Mach)

If we finish #6227 within reasonable timeframe, this can be rejected, otherwise we might need to dust this off.

Actions #4

Updated by Pavel Kácha over 3 years ago

  • Related to Feature #6227: Incorporate new info from Negistry into group db and reporting added
Actions #5

Updated by Pavel Kácha over 2 years ago

  • Target version changed from 2.9 to Backlog
Actions #6

Updated by Rajmund Hruška almost 2 years ago

#6227 is closed, so I guess this can be closed as well? Pavel Kácha

Actions #7

Updated by Pavel Kácha almost 2 years ago

Negistry does not (yet) sell the Metacentrum data, also group name will most probably not correspond and will need some tweaking. We could close this, but then we would need another (quite similar) issue to track it.

Actions #8

Updated by Rajmund Hruška about 1 year ago

  • Status changed from Deferred to Feedback

Pavel Kácha, as we have discussed earlier, it is possible to add any list of networks from any source. We just need to setup the cronjob which downloads the data in the same format as we get from negistry (described here: https://alchemist.cesnet.cz/mentat/doc/development/html/_doclib/apidoc/mentat.module.netmngr.html#whois-file-format) and another cronjob for running the import script.

Actions #9

Updated by Pavel Kácha about 1 month ago

  • Is duplicate of Feature #7725: Import Metacentrum networks as an externally updated feed added
Actions #10

Updated by Pavel Kácha about 1 month ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF