Project

General

Profile

Actions

Bug #7549

closed

Missing flag for Réunion

Added by Radko Krkoš over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Development - GUI
Target version:
Start date:
01/27/2022
Due date:
% Done:

20%

Estimated time:
To be discussed:
No

Description

A flag picture displayed for country resolution next to ISO code does not display correctly for Réunion. Proof: https://mentat-hub.cesnet.cz/mentat/events/10372-PDNS-22203-2022027-133-CRYPTO-29158-11521-30578/show
The link seems to be correctly formated: https://mentat-hub.cesnet.cz/mentat/static/images/country-flags/flags-iso/shiny/16/RE.png , so the file is probably missing.

Actions #1

Updated by Radko Krkoš over 2 years ago

  • Subject changed from Mising flag for Réunion to Missing flag for Réunion
Actions #2

Updated by Radko Krkoš over 2 years ago

  • To be discussed changed from No to Yes

Now I get 500 when accessing the RE flag resource, before it was 404.
A peek to Apache error log at mentat-hub confirms this.

Actions #3

Updated by Radko Krkoš over 2 years ago

Same on mentat-alt, returns 500.

Actions #4

Updated by Radko Krkoš over 2 years ago

A quick analysis shows that the error is somewhat deeper as the web fails with 404 sometimes, which is expected as the file is missing, but with 500 other times. This was confirmed on both production and testing and also by Rajmund Hruška.

Actions #5

Updated by Jan Mach over 2 years ago

  • Assignee set to Jan Mach

The icon file is indeed missing. The 500 error is due to the fact, that default flask error handling is customized to be nicer for user. However when serving static files it would be better to just return plain HTTP HEAD 404 with no content. Trying to return personalized error page. Because it was a request for static file, there is no user identity and customized error page cannot be rendered anyway.

I'll take this one, if I may.

Actions #6

Updated by Jan Mach over 2 years ago

  • To be discussed changed from Yes to No
Actions #8

Updated by Jan Mach over 2 years ago

  • Status changed from New to In Progress
  • Priority changed from Low to Normal
  • % Done changed from 0 to 20
Actions #9

Updated by Jan Mach over 2 years ago

  • Target version changed from Backlog to 2.10
Actions #10

Updated by Pavel Kácha almost 2 years ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF